You are here

12 posts / 0 new
Last post
Luminar not showing as editing Extension in Apple Photos #1
Thomas Emmerich's picture
by Thomas Emmerich
November 26, 2016 - 11:52pm


Thomas Emmerich's picture
by Thomas Emmerich
November 27, 2016 - 12:02am

Not sure what happened to my previous post text. All that shows is the title.

Luminar doesn’t show up as an editing extension nor in the System Preferences Extensions panel.

I’m running MacOS 10.12.1 and Luminar 1.0.1. Any ideas?


AHolmes's picture
by AHolmes
November 27, 2016 - 7:33am

Hi Thomas,

Not sure what to suggest. I am running the same versions of macOS and Luminar, but am not having a problem using Luminar as an extension of Photos.



Yoav from Picktorial's picture
by Yoav from Picktorial
November 28, 2016 - 7:51pm

I would try to uninstall using App Cleaner (free download from here), reinstall to the Applications folder, open the standalone app once and try again to add the Photos extension in the system preferences panel.

Picktorial can natively browse Aperture libraries and provides powerful non-destructive editing tools.

Thomas Emmerich's picture
by Thomas Emmerich
November 29, 2016 - 6:49am

Thanks for the responses. I have contacted MacPhun support and they suggested the same steps as Yoav. I removed Luminar using AppCleaner and reinstalled it. No success.

Oddly, it works as an extension in my two other accounts on this Mac. Just not on “my” account.

There’s got to be some corrupt file in my user account preventing it from working. All my other MacPhun apps work fine as well as other photo apps.


Thomas Emmerich's picture
by Thomas Emmerich
December 7, 2016 - 5:07pm

An update to my issue: Solved!

The steps provided by MacPhun support never did end up working. But I tried my own step of running the Maintenance tools inside of Onyx. I did two of the options under Maintenance so I don’t know which one actually fixed my problem. The fix permissions option was a likely candidate.

I had previously run the Clean options in Onyx without results. This option cleans out various user and system caches.


Pelyma's picture
by Pelyma
December 20, 2016 - 12:52pm

Hi Thomas, I’m having exactly the same problems, what tools did you run on Onyx?


Thomas Emmerich's picture
by Thomas Emmerich
December 20, 2016 - 10:42pm

I think the fix was the permissions fix under the Maintenance section.


Pelyma's picture
by Pelyma
December 21, 2016 - 1:45pm

Thanks Thomas, Macphun have taken me through some other routes and the final one worked! Great service from Macphun they really went the extra mile.

SonomaTom's picture
by SonomaTom
July 8, 2017 - 3:41pm

Hi Thomas and Pelyma,

I just purchased Luminar 1.2 directly from MacPhun and I am having the same problem that both of you reported. MacPhun has logged my issue, but has not come back to me yet with any advice.

I tried the App Cleaner uninstall, and then reinstalled and reactivated Luminar, but that did not fix the problem.

I also experienced the same thing reported by Thomas - I could log-in as another user on my iMac, activate Luminar, and then Luminar DID show up as an option for an editing extension. But still not visible in my primary, administrator account. Bizarre!

Any tips or suggestions from anyone would be greatly appreciated.



SonomaTom's picture
by SonomaTom
July 8, 2017 - 5:09pm

UPDATE - Problem solved using step-by-step instructions provided by MacPhun support, which I’ve reproduced below as reference:

In order to fix this issue you need to simply remove Luminar with AppCleaner, empty Trash, reinstall it and restart Mac. 

Here’re some links you may need if you execute the instructions:

Luminar installer:  

App Cleaner:  

Here are the crucial steps:

1. Don’t launch Luminar before restarting Mac. Here’s how to install Luminar.

    • Locate the installer (Luminar_main.dmg).
    • Double-click to launch the installer and begin the installation process.
    • Please make sure to click and hold on the Luminar icon and drag it into the Applications folder. See screenshot attached.

    • Wait until Luminar is copied into the Applications folder.
    • It is recommended to unmount the disk image.
2. When you restart your Mac make sure that “Reopen windows when logging back in” is not marked. This ensures that all previous errors are erased from memory. 

3. After restart, find Luminar in Applications folder, launch it from there, and if prompted - enter your Mac password. 

4. Load some image into Luminar and check Extensions after.


JohnE's picture
by JohnE
October 5, 2017 - 2:35pm


My solution included using the CleanMyMac 3 app. 
As written above, (using the Onyx software), the solution was to go to ’Maintenance’ and run ‘Repair Disk Permissions’. 


You may login with either your assigned username or your e-mail address.
Passwords are case-sensitive - Forgot your password?