You are here

7 posts / 0 new
Last post
Aperture 3.3 imports raw+jpg pairs seperately #1
Dave Parry's picture
by Dave Parry
June 19, 2012 - 7:00am

Hi all

I updated Aperture to 3.3 the other day and today is the first time I've had to import files. I imported a load of raw and associated jpgs as normal from a folder (copied from memory card onto hard drive) as reference files into aperture. This is the way I've always worked in Aperture. Anyway, as normal I have the import set to import raw+jpg pairs as one and set the jpeg as the master/original.

The problem is that now regardless of the “Both (use jpeg as original)” setting Aperture is intent on importing both the raw and jpeg as separate files.

I've managed to rule out any problem with the files themselves - they are filenamed properly, and infact file pairs I imported only last week into the previous version of Aperture now won't import as pairs anymore. It would seem to be something to do with the new 3.3 version. I've also tried the “Import folders as projects” and this has the same problem.

Anyone any ideas?

Dave Parry's picture
by Dave Parry
June 20, 2012 - 7:05am

Update - I’ve established this problem afflicts the raw+jpg pairs from my Panasonic GF1, but the raw+jpg pairs from my wife’s Canon S95 import correctly.

Anyone any ideas at all?

Dave Parry's picture
by Dave Parry
June 20, 2012 - 4:56pm

OK I found reference to similar behaviour and other raw-related problems with Panasonic files on other forums. It turns out this bug came in with a recent OS X update - I had just updated my system to Lion in order to update to Aperture 3.3. Presumably Apple will sort this in a future system update.

Running the following code in Terminal solves the problem:

/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -R /System/Library/CoreServices/CoreTypes.bundle/Contents/Library

David  Moore's picture
by David Moore
June 20, 2012 - 10:53pm

So you are saying that you did this and it Works!!! Yea. Ive heard of other Frameworks/ core services problems and thought the only fix was to reinstall Aperture. Congradulations and thanks for keeping all of us informed.
Twitter= @davidbmoore
Scottsdale AZ

Martin Herrera's picture
by Martin Herrera
April 12, 2013 - 5:35am

Guy, it’s now April 2013, and I just imported for the first time RAW + JPG (in one instance with RAW as the master and on another instance the other way around). In both cases, both the RAW + JPF files are copied onto my external drive where I keep my files, but only one, which ever I chose as the master, gets imported into the library. Put another way, if I import RAW + JPG with JPG as master (which I like to do when I import Black and White), both files are copied and renamed to the destination drive, but only the JPGs appear in the Aperture Library Project.

My understanding was that they should both be imported and actually stacked. Any ideas? Would the offered solution for before work for this as well? Has anyone else experienced this problem?

Thanks so much for the help. Martin.

Martin Herrera Soler |

Thomas Emmerich's picture
by Thomas Emmerich
April 12, 2013 - 6:54am


If you need to see both the RAW and JPEG inside the library at the same time, choose “Both (Separate Masters)” from the RAW+JPEG import setting. The other two options do import both files but will only show one at a time. You can switch between seeing the JPEG or RAW as master using the contextual menu when right-clicking on an image. Unfortunately there is no way, once you’ve imported using JPEG as master or RAW as master to switch Aperture to show both at the same time (i.e. the Separate Masters import setting). If you want them separate in the library you need to import them that way.


Martin Herrera's picture
by Martin Herrera
April 12, 2013 - 7:51am

Thanks so much Thomas. I had never actually noticed that option. Works exactly as you mentioned. Thanks. m.

Martin Herrera Soler |

You may login with either your assigned username or your e-mail address.
Passwords are case-sensitive - Forgot your password?