You are here

7 posts / 0 new
Last post
orange file symbol appears instead of image after slowing down, crashing frequently #1
Susan S's picture
by Susan S
February 28, 2013 - 3:13pm

Using Aperture 2 with Lion 10.7.5 on early 2008 Macbook Pro (2.6 GHz Intel Core 2 Duo) with added harddrive (350GB free.)
Just added 200 Canon raw files as a new project. While sorting, adding keywords and making adjustments, Aperture 2 “quit” several times. Adjustment tools were acting wacky and everything was slowing down. Then when I clicked on a thumbnail that I had viewed and edited previously, instead of the image, I saw a large orange file symbol with a message… something about corrupted file, unable to open? I decided to delete that master. But then it started happening on every thumbnail that I clicked on to view. I quit Aperture and have opened hours later. I am able to view the files in question.
Before I start working again, I wonder if I should do maintenance. I have never repaired preferences or database. I looked at FAQs, but and not clear what I should do or do first. I have a Managed Library and have backed up with Vault (altho not in last month.)
Advice before I proceed would be appreciated.

Susan S

Susan S's picture
by Susan S
March 4, 2013 - 1:53pm

Thanks for your input!
DB Moore,
I Have repaired permissions on my HD and rebooted. Then reopened Aperture, did some work on the same set of photos and eventually had the same orange/red file symbol. The message actually referred to “unsupported file”. I could not see where you were referring to the Photo Menu to generate the new thumbnail and preview.
I tried opening Aperture with the command shift to try the three steps of maintenence in Aperture (remember I am using 2.1.4). Instead of getting the 3 options box (as shown in the maintence page of FAQs) it only gives me the choice to do a consistency check or rebuild database. I chose to do the consistency check. It ran “vacuum of database” and then opened Aperture. (Does not show any result from check.)
Should I now rebuild database?
Should I update my Vault before I rebuild or after?
It sounds like I should update to APerture 3 ASAP, but am worried after reading Kathy’s post.
Of course all of this has occurred just when I need to be working on a project when others are waiting for photos to be delivered.
Thanks for contined guidance and clarfication.

Susan S

David  Moore's picture
by David Moore
March 5, 2013 - 12:23am

The top menu bar has a drop down menue called photo. Go there and look at the bottom for Thumbnail and preview build or generate. Try the option key when looking at those choices and try it with the option key also. On your question to rebuild data base … Yes. Rebuilding of the data base a week or two before an upgrade to a new version is a good Idea along with new back ups the day before. Cheers
Twitter= @davidbmoore
Scottsdale AZ

Susan S's picture
by Susan S
March 25, 2013 - 1:15pm

I discovered tonight that I am missing several projects (projects of hundreds of iphone photos that I have deleted from phone.) I keep these projects in one place so that I can easily check to see what I have imported (and usually keyworded) before I clear space on my iphone 4gs. When I looked today several Projects are missing. It looks like it did months ago, but the new Project that I imported last month from my CanonG11 is still exists. I was about to update my Vault when I discovered this so did not go ahead. I searched the saved deleted files in my Vault and although I found a few iphone and instagram photos, the missing projects are not there. Could they have disappeared when I rebuilt my database? How can I check my latest Vault to see i they still exist there without losing my current aperture (which includes more recent Projects)? I also have a complete harddrive backup and wonder how I could go about checking to see if they exist in that backup. I have never had to go searching for missing Projects before! This will be very sad if they are really gone. Over a year’s woth of iphone photos (and saved Instagram images) missing.

Susan S

David  Moore's picture
by David Moore
February 28, 2013 - 10:22pm

Hi Susan
When you get the warning sign on a thumbnail go to the photo menu and at the bottom are two option. one is for thumbnails and one is for previews. by holding the option key the the choice changes to generate new preview. Do the thumbnail and then generate new preview.
Just restarting can do a lot of good fixing problems which you did and now the previews show. very basic mac maintenance would be re booting. next reboot in safety mode and start again, Next use Disk utilities to repair permissions on the main HD. then do the three steps of Apertures repair and rebuild procedure. Do those first and if still experiencing problems write back.
cheers dbm
Twitter= @davidbmoore
Scottsdale AZ

monotypemaker's picture
by monotypemaker
March 2, 2013 - 3:56am

Hi Susan,
I don’t want to scare you, but think you should hear my tale of woe. I was happily using Aperture since it’s beginnings in 2006. Was up to Aperture 2.1.4. For many reasons, late last year I had to upgrade my old G5 pre-Intel desktop to a new-used 2009 MacPro w 2TB harddrive for photos and a solid state hd for all applications.

I kept slightly older Snow Leopard os since my 2006 macbook pro laptop couldn’t go higher than that, and Aperture 2.1.4 had always worked fine, and I needed them to match. Everything was wonderful for about a month, when suddenly, for the first time ever, Aperture quit. Would not open, period. Had been getting what you describe with the thumbs. I would reboot. Sometimes all would return, then a day or two later, gremlins would return and crash again. For a week I just kept rebooting. This was in January.
Somehow, after a week of this instability, things calmed down. I gradually saw the pictures return, as if something was rebuilding them. I was thrilled. Worked hesitantly and watchfully for about a month with NO issues at all. Then, all of a sudden, again, I could not open Aperture 2.1.4 anymore. Not even rebooting. (If you read my posts beginning Feb 24, you’ll have a more thorough story.)

I had been postponing upgrading to Aperture 3+ because everything had worked fine till then. But at this point, decided to buy a newer laptop to match my newer desktop, upgrade to Mountain Lion on both, and make the big jump, hoping it was only Aperture 2 that was screwed up (on the solid state drive) and not my library (all my images since 2003), which were safely (I thought!) on the 2TB HD.

Long story short, Aperture 3 began the upgrade process, what I expected would take a long time, as library was 2.90 gigs. I had checked and rechecked the size of the library many times before the process, to confirm 2.90 gigs. So it was there. The upgrade quit a couple times, so I proceeded with a “Library Repair.” Upgrade finished quickly, then! But to my shock, it was because the library size was now only 9mb! My entire library was gone.
I want to believe the library was thoroughly corrupted during the weeks of crashing—and not the fault of Aperture 3… But truly have no idea. Fortunately, still have almost a complete copy of this library (not the vault, but a straight-up copy) on my old desktop (pre-intel G5).

Still spooked about transferring this library into the new desktop to try again. Have made another copy of it on same G5, though, so getting up nerve. Still would feel better if it was safely on an entirely different ext hard drive.

No moral to this story except BEWARE when funky stuff starts happening with old Aperture 2, straddling into newer operating systems. It is NOT Stable. Anything can happen. Whatever you do: Copy your library elsewhere, immediately!!!
Good luck!


Walter Rowe's picture
by Walter Rowe
March 2, 2013 - 5:01am

Both of your stories make an excellent argument for keeping software up-to-date. Going from a very old version all the way to the latest version in one shot is probably not what Apple anticipated in their upgrade code.

You may login with either your assigned username or your e-mail address.
Passwords are case-sensitive - Forgot your password?