You are here

2 posts / 0 new
Last post
Lost a folder #1
John Caradimas's picture
by John Caradimas
May 7, 2015 - 12:19pm

Guys, new member here, and I badly need your help.

I have my Aperture library organized using folders for years, then more folders for months and in the months I have projects with the various events I shoot. All of a sudden, I noticed that my 2012 folder is missing, as well as the various months from inside the 2012 folder. I can see the projects that were inside those folders, but the whole year-months structure is gone. My questions are:

- How did that happen? I mean is it possible to delete a folder, without deleting all the projects inside it?

- Is there anyway I can recover my structure??

I’ve checked all my other folders, just in case I’ve accidentally moved it somewhere, but I can’t find it.

Needless to say, all help would be greatly appreciated.

 

David Edge's picture
by David Edge
May 8, 2015 - 1:46am

Hi John

Back up or ensure you are backed up then open Aperture with Cmd-Option-Click which will give you three first aid options:

- repair permissions

- repair database

- rebuild database

These are in order of increasing effectiveness but risk! So try repair permissions (unlikely to fix); then repair database. Frankly if that doesn’t fix it I think it would be easier to move projects back to the folder than to mess about with rebuild. Just a gut feeling.

Not a clue how it happened. things sometimes get tangled up if Aperture crashes (which it does!).

d.

You may login with either your assigned username or your e-mail address.
Passwords are case-sensitive - Forgot your password?
randomness