You are here

8 posts / 0 new
Last post
Library Permissions Repair - Help! #1
faphoto's picture
by faphoto
March 4, 2011 - 11:54am

I am looking for help and came across your site. I am still running aperture 2, scared to upgrade to 3 after reading lots of forums. I have an aperture library (with managed images) on an external drive that will not open due to “permission” issues. I have two other libraries on this same external drive that open and operate completely fine. Is there any trick to overriding the permission issue on the one library? I can see the contents when i click on “show package contents”, it just wont let me open anything related to that library because of a permission issue. It has happened all of a sudden, this library was working fine just last week. I really need to get to some books I am working on for a client. Any ideas would be greatly appreciated! Thank you! (Also, i have already tried “repairing the permissions”, the progress bar gets to about 70% and goes no further. Any other ideas?)

PhotoJoseph's picture
by PhotoJoseph
March 4, 2011 - 1:37pm


Glad you found the site, and I can assure you—there’s nothing to be afraid of with Aperture 3 ;-)

However before you upgrade, let’s get your damaged Library working. A you’ve clearly found, Aperture actually has a built-in first aid tool, that you activate by holding down Command-Option while launching.

Before you do anything, please make a backup of your entire Library. Just copy it to another drive or duplicate it so you have a second copy. I realize this may take a lot of space, but it’s a lot easier to get back to where you started by doing this than relying on a Time Machine backup or restoring from the cloud. Then…

You’ve tried repairing permissions already. How about repair or rebuild database? Aperture gives more than one option; you definitely should try the others next.

Once your library is up and running, you can upgrade to Aperture 3. Again, you should have backups of your Libraries before proceeding. I don’t say this because of any inherent problems with Aperture, I say this because of inherent problems with all computers and all software. Any major upgrade of anything should always be preceded by a backup. Always.

Good luck
-Joseph @ApertureExpert

— Have you signed up for the mailing list?

faphoto's picture
by faphoto
March 4, 2011 - 5:14pm

Thanks for your help! I just ordered a new 1tb hard drive to back everything up, once that is done I will try rebuilding the library to see if that does the trick! Thanks

faphoto's picture
by faphoto
March 19, 2011 - 11:49pm

Well, I got my backup drive, and backed up everthing. Then i tried rebuilding the permissions again and it just keeps getting stuck about 75% of the way. Then i moved on, and tried rebuilding the whole library but it wont even let me use that option. When i click on that button the same error message:

“To use this library, make sure its file permissions are set correctly”

I dont know what to do, I am seriously going to lose some important stuff if i can’t access this library! The frustrating thing is i can still “show package contents” and see all the files inside. I’ve been reading about some people deleting certain files and their libraries working again, any thoughts?

Any help would be greatly appreciated!!


Thomas Emmerich's picture
by Thomas Emmerich
March 20, 2011 - 3:01am

One thing you can try since your library is on an external drive is to enable “ignore ownership” on the entire drive. That should alleviate any permissions issues.

To do that, perform the get info command (<command> I) at the root level of the drive. At the bottom of the get info window you’ll see the “ignore ownership on this volume” checkbox. It is in the “Sharing & Permissions:” section. You may need to expand this section to see it by clicking the arrow. If the setting is grayed out (likely), click the padlock icon and enter an administrator’s username and password.


faphoto's picture
by faphoto
March 21, 2011 - 5:12am

Thomas! You’re the man! The permissions thing worked! I also learned this this experience that when i add an external hard drive I need to reformat it to Mas OS Extended (Journaled). I had never done that, but did it with my new hard drive and I think that’s why I could see the permissions checkbox. My other drives dont have that option.

Question: Could having this box unchecked cause me issues moving forward? I am not on a network and no one else has access to these drives.

PhotoJoseph's picture
by PhotoJoseph
March 22, 2011 - 6:04am


Glad to hear it’s sorted out. Yes, you can leave “ignore permissions” enabled for all of your external drives.

Can you rebuild permissions now on your Library?

-Joseph @ApertureExpert

— Have you signed up for the mailing list?

tricky01's picture
by tricky01
September 24, 2012 - 4:43am

Sorry to drag out this old post, but I’ve been having a problem with permissions and trying all of the above suggestions failed for me; the ‘Ignore ownership on this volume’ just didn’t appear at all.

After much searching I found the solution to my problem over here:

The problem is that the drive i’m trying to open the library from is a TimeMachine backup. This is not possible and instead one must restore the backup to a drive first and then open it (and which point the library can be updated to the latest version so as to be viewable.

I rewad this site’s post on backups a few weeks ago and I think it’s a real disappointment that you can’t open backups directly from TimeMachine. In my case, one project got corrupted in my current library and it’s an old backup I need to restore from. All I want is this one project of perhaps 200 RAW files, the edits and one Book I designed from these. To have to copy the 400gb library out of TimeMachine just to export these perhaps 8gb of files is really annoying!

Anyway, I hope this helps others :)

You may login with either your assigned username or your e-mail address.
Passwords are case-sensitive - Forgot your password?